Honda CRF1000L Africa Twin Forum - View Profile: FarangMoto

FarangMoto FarangMoto is offline

Member

  Statistics

Total Posts
General Information
  • Last Activity: 04-20-2017 12:27 AM
  • Join Date: 01-26-2017
  • Referrals: 0

  Mentions

02-13-2017
07:12 AM - dadrob mentioned FarangMoto in post my African African Twin
FarangMoto yyeah the firs...

  Quotes

04-15-2017
03:53 PM - Jambo quoted FarangMoto in post Attacked by both front and rear footpegs.
Not sure about your neck of the...
04-08-2017
12:42 AM - Coast2Coast quoted FarangMoto in post Attacked by both front and rear footpegs.
Not sure about your neck of the...
04-07-2017
08:00 AM - FarangMoto quoted Derek Dust in post Attacked by both front and rear footpegs.
I took the rear pegs off, but j...
03-28-2017
10:30 PM - SkipD quoted FarangMoto in post Loud pop/pufft from the throttle bodies
^ Cheers. Just curious, but...
03-27-2017
11:27 PM - Vintage_Snyder quoted FarangMoto in post Loud pop/pufft from the throttle bodies
On occasion, I get a loud pop f...
11:24 PM - Vintage_Snyder quoted FarangMoto in post New tires order went very badly
I had Pirelli MT60 installed o...
03-19-2017
09:27 AM - FarangMoto quoted Ray Tuggley in post Ey Up from the Republic of South Yorkshire
Thailand!! By Ek that's a long c...
03-10-2017
06:42 AM - Ray Tuggley quoted FarangMoto in post Ey Up from the Republic of South Yorkshire
How tha doin' thee? Another S....
03-08-2017
05:11 AM - Denburger quoted FarangMoto in post Another chain tension question?
Can anyone confirm the actual t...
01-31-2017
04:08 AM - eltel62 quoted FarangMoto in post Africa Twin 12v outlet
When I bought the bike I had Ho...
01-30-2017
08:13 AM - FarangMoto quoted funkymunky in post Stock Pegs Suck!
I dropped my AT twice, once per...
01-29-2017
03:39 PM - FrogAT quoted FarangMoto in post CRF Rally (Red/Black/White) Africa Twin Owners Picture Thread
Here is mine. Only had it a ...
09:31 AM - FarangMoto quoted Yak in post Bar Risers
Just an FYI for those pu...
 
For the best viewing experience please update your browser to Google Chrome