Instrument cluster - Honda CRF1000L Africa Twin Forum
 
Thread Tools
post #1 of 6 (permalink) Old 04-17-2019, 04:21 AM Thread Starter
Junior Member
 
Join Date: Oct 2018
Location: Neath South Wales
Posts: 15
Instrument cluster

Hi all has anyone had water on the inside of the glass in the instrument cluster on the 2018 model AT as mine is going in to be sorted.
Spooky is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-17-2019, 04:42 AM
Member
 
Join Date: Jul 2018
Location: South Gloucestershire
Posts: 70
Quote:
Originally Posted by Spooky View Post
Hi all has anyone had water on the inside of the glass in the instrument cluster on the 2018 model AT as mine is going in to be sorted.
Yes, occasionally I notice what looks to be condensation on the inside of mine. Will report it when it goes in for service in July.
Maxply is offline  
post #3 of 6 (permalink) Old 04-17-2019, 06:42 AM
Senior Member
 
Join Date: Nov 2018
Location: Nottingham UK
Posts: 335
Yes. I immediately took it back to the dealership. they saw it and then went onto their official 'dealer only' Honda site.. and told me this was a "known Issue". Photographs were taken, the warranty 'repair' was quickly approved, Parts were ordered and Im still awaiting a call to take the bike in for the swap to be done. this was reported BEFORE Christmas.

I at first thought it was something like an oil.. it didn't look like water, perhaps due to the coating on the inner surface, however it subsequently disappeared without leaving a 'mist' and hasnt come back. Im still having it changed though.

30th anniversary DCT 'Sport.
Motobiker is online now  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 04-18-2019, 05:40 AM Thread Starter
Junior Member
 
Join Date: Oct 2018
Location: Neath South Wales
Posts: 15
I can see like a plastic paper in the top right hand corner looks like it has come from inside i don't want to pull it just in case all the guts comes out Lol.
Spooky is offline  
post #5 of 6 (permalink) Old 04-19-2019, 03:40 AM
Senior Member
 
Scorch Dugan's Avatar
 
Join Date: May 2018
Location: Victoria, Australia
Posts: 131
Garage
Quote:
Originally Posted by Motobiker View Post
Yes. I immediately took it back to the dealership. they saw it and then went onto their official 'dealer only' Honda site.. and told me this was a "known Issue". Photographs were taken, the warranty 'repair' was quickly approved, Parts were ordered and Im still awaiting a call to take the bike in for the swap to be done. this was reported BEFORE Christmas.

I at first thought it was something like an oil.. it didn't look like water, perhaps due to the coating on the inner surface, however it subsequently disappeared without leaving a 'mist' and hasnt come back. Im still having it changed though.
I had the same thing when my bike was weeks old. It disappeared and hasn't returned. That was nearly a year ago now. I think I'm in the clear! Famous last words!

The more you've found, the less you've been around.
Scorch Dugan is offline  
post #6 of 6 (permalink) Old 04-19-2019, 06:32 AM Thread Starter
Junior Member
 
Join Date: Oct 2018
Location: Neath South Wales
Posts: 15
Quote:
Originally Posted by Motobiker View Post
Yes. I immediately took it back to the dealership. they saw it and then went onto their official 'dealer only' Honda site.. and told me this was a "known Issue". Photographs were taken, the warranty 'repair' was quickly approved, Parts were ordered and Im still awaiting a call to take the bike in for the swap to be done. this was reported BEFORE Christmas.

I at first thought it was something like an oil.. it didn't look like water, perhaps due to the coating on the inner surface, however it subsequently disappeared without leaving a 'mist' and hasnt come back. Im still having it changed though.
The parts should be in your dealership 72hrs after Honda approved it mine is booked in a week Monday.
Spooky is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Honda CRF1000L Africa Twin Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Cluster - 2017 Model Omsracer Honda CRF1000L Africa Twin General Discussion Forum 2 09-20-2018 09:11 AM
Instrument panel melting mjc14850 Electronics 12 06-05-2018 11:47 PM
DUST on instrument screens Ridenfun Honda CRF1000L Africa Twin General Discussion Forum 7 06-14-2017 12:32 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome