Honda Africa Twin Forum banner
  • Hey everyone! Enter your ride HERE to be a part of July's Ride of the Month Challenge! Theme: Drop it like it's hot!
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Installed the Denali S4 lights with a Eager Beaver 3cs hook up, lights still won't work. Anyone have a problem with the AT and Denali lights?
 

·
Registered
Joined
·
371 Posts
Some LED lights are polarity sensitive. Did you hook up the positive and negative wires from the lights correctly - you could try and reverse the connections and see if they go on.
 

·
Registered
Joined
·
577 Posts
Installed the Denali S4 lights with a Eager Beaver 3cs hook up, lights still won't work. Anyone have a problem with the AT and Denali lights?
Denali LED lights come with three wires and if you use their premium wiring loom (sold separately) unless you bought a kit,
you cannot mess it up.
If you want to take advantage of the "Data Dim" technology, you also need to have the controller- sold separately.
Pricey but makes the install easy.
 
  • Like
Reactions: Cuchulainn

·
Administrator
Joined
·
3,288 Posts
Denali LED lights come with three wires and if you use their premium wiring loom (sold separately) unless you bought a kit,
you cannot mess it up.
If you want to take advantage of the "Data Dim" technology, you also need to have the controller- sold separately.
Pricey but makes the install easy.
I went with the DataDim and Switch Eliminator kits and that works for the way I want them to operate.
 

·
Registered
Joined
·
295 Posts
So, I may have an answer to this old post. I installed S4s today. Hit the switch and nothing I figured out after a few minutes there was additional steps on the back of the page. Even though I was using my Eastern Beaver PC8 I had to connect one of the lines to a switched power. Easy enough I just posi-tapped into the hot wire to the battery. This works as the PC8 is a switched unit... Just a thought! Now I have to adjust them!
 
1 - 5 of 5 Posts
Top