Honda Africa Twin Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Hi all has anyone had water on the inside of the glass in the instrument cluster on the 2018 model AT as mine is going in to be sorted.
 

·
Registered
Joined
·
94 Posts
Hi all has anyone had water on the inside of the glass in the instrument cluster on the 2018 model AT as mine is going in to be sorted.
Yes, occasionally I notice what looks to be condensation on the inside of mine. Will report it when it goes in for service in July.
 

·
Registered
Joined
·
409 Posts
Yes. I immediately took it back to the dealership. they saw it and then went onto their official 'dealer only' Honda site.. and told me this was a "known Issue". Photographs were taken, the warranty 'repair' was quickly approved, Parts were ordered and Im still awaiting a call to take the bike in for the swap to be done. this was reported BEFORE Christmas.

I at first thought it was something like an oil.. it didn't look like water, perhaps due to the coating on the inner surface, however it subsequently disappeared without leaving a 'mist' and hasnt come back. Im still having it changed though.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #4
I can see like a plastic paper in the top right hand corner looks like it has come from inside i don't want to pull it just in case all the guts comes out Lol.
 

·
Registered
Joined
·
145 Posts
Yes. I immediately took it back to the dealership. they saw it and then went onto their official 'dealer only' Honda site.. and told me this was a "known Issue". Photographs were taken, the warranty 'repair' was quickly approved, Parts were ordered and Im still awaiting a call to take the bike in for the swap to be done. this was reported BEFORE Christmas.

I at first thought it was something like an oil.. it didn't look like water, perhaps due to the coating on the inner surface, however it subsequently disappeared without leaving a 'mist' and hasnt come back. Im still having it changed though.
I had the same thing when my bike was weeks old. It disappeared and hasn't returned. That was nearly a year ago now. I think I'm in the clear! Famous last words!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
Yes. I immediately took it back to the dealership. they saw it and then went onto their official 'dealer only' Honda site.. and told me this was a "known Issue". Photographs were taken, the warranty 'repair' was quickly approved, Parts were ordered and Im still awaiting a call to take the bike in for the swap to be done. this was reported BEFORE Christmas.

I at first thought it was something like an oil.. it didn't look like water, perhaps due to the coating on the inner surface, however it subsequently disappeared without leaving a 'mist' and hasnt come back. Im still having it changed though.
The parts should be in your dealership 72hrs after Honda approved it mine is booked in a week Monday.
 
1 - 6 of 6 Posts
Top