Honda Africa Twin Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Recently purchased a new 2019 Adventure Sports DCT. At right around 500 miles the bike won't start. It cranks over just fine and it getting spark. I think I might already be experiencing the clogged fuel filter-pump-injectors I found out about right after I purchased the bike. I'll be taking it in to the dealer on Saturday June 27th. We'll see what happens. So far I'm not filled with confidence.
 

·
Super Moderator
Joined
·
1,948 Posts
Hi and welcome
Sorry to read about your issue, hopefully it’s fixed soon..
 

·
Super Moderator
Joined
·
3,049 Posts
That is unsatisfying to say the least Bakoboy. Maybe take a peak inside the tank to confirm your suspicions.

You will be past this one way or another.

Meanwhile, welcome to the Forum.
 

·
Administrator
Joined
·
1,763 Posts
Sorry to hear about your issues. Please do follow up and let us know if this turns out to be the case or not. If not I would be curious to know what the issue is.

I hope they get you back on the road soon and you don't miss too much of the summer riding season!

Sent from my SM-N975U1 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Just picked up my ATAS from the service department and it was the clogged fuel pump issue I had feared.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #7
It was covered under warranty. Some guys have had it happen multiple times and some have not. Either way, I don't think I can count on the bike to be reliable for the long distance off-road trips I purchased it for. I can just imagine being up in the mountains miles from civilization when the fuel pump or injectors get clogged again.
 

·
Super Moderator
Joined
·
3,049 Posts
Hey, @Bowieeeeeeeeee???????????? Welcome to the Forum.

Do you mean this issue?

 

·
Registered
Joined
·
18 Posts
Hey, @Bowieeeeeeeeee???????????? Welcome to the Forum.

Do you mean this issue?

Yep, thanks.
 
1 - 10 of 10 Posts
Top