Honda Africa Twin Forum banner
  • Hey everyone! Enter your ride HERE to be a part of July's Ride of the Month Challenge! Theme: Drop it like it's hot!
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all, I have a normal 2016 (not DCT version). 2 days ago the traction control button stopped working. There isn't any weird lights in the dash and it shows the full 3 bars of the traction control. Has anyone had this issue? I don't seem to fine anything on the forums.
I'll try some contact cleaner fluid to see how it goes.
Other question, is there a way to fully disengage the traction control? Like a fuse?
 

·
Registered
Joined
·
166 Posts
It's probably similar to the sticky set switch issue. I'd have it replaced under warranty if you can.
You can turn off traction control by long pressing the button.
 

·
Registered
Joined
·
415 Posts
Hi all, I have a normal 2016 (not DCT version). 2 days ago the traction control button stopped working. There isn't any weird lights in the dash and it shows the full 3 bars of the traction control. Has anyone had this issue? I don't seem to fine anything on the forums.
I'll try some contact cleaner fluid to see how it goes.
Other question, is there a way to fully disengage the traction control? Like a fuse?
Just pull the the trigger on the traction control button and its off (it only takes a fraction of a second). If you pull and release it steps to the next level, pull and hold for a fraction longer and its instantly off even if TC had cut in.
 
1 - 4 of 4 Posts
Top